Piwik 0.6 < 0.6.4 Remote File Include Vulnerability

High Nessus Network Monitor Plugin ID 5618

Synopsis

The remote web server is hosting a PHP application that is vulnerable to a remote file include attack.

Description

The remote web server is hosting Piwik, a web analytics application written in PHP. Versions of Piwik 0.6 &lt; 0.6.4 are potentially affected by an unspecified remote file include vulnerability. An attacker, exploiting this flaw, could read arbitrary files or potentially execute arbitrary script code subject to the privileges of the affected web server.

Solution

Upgrade to Piwik 0.6.4 or later.

See Also

http://piwik.org/blog/2010/07/piwik-0-6-4-security-advisory

http://piwik.org/blog/2010/07/piwik-0-6-4

Plugin Details

Severity: High

ID: 5618

File Name: 5618.prm

Family: CGI

Published: 2010/07/30

Modified: 2016/01/15

Dependencies: 1442

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 6.8

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

Patch Publication Date: 2010/07/20

Vulnerability Publication Date: 2010/07/28

Reference Information

CVE: CVE-2010-2786

BID: 42031