MapServer < 5.6.4 / 4.10.6 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 5611


The remote web server contains a CGI script that is vulnerable to multiple attack vectors.


The remote web server hosts MapServer, an open source platform for publishing spacial data and interactive mapping applications to the web.

Versions of MapServer earlier than 5.6.4, or 4.10.6 are potentially affected by multiple vulnerabilities :

- A buffer overflow vulnerability in the 'ForcedTmpBase' parameter of 'msTmpFile()'. (Ticket 3484)

- Unspecified security vulnerabilities in multiple debug command-line arguments. (Ticket 3485)


Upgrade to MapServer 4.10.6, 5.6.4, or later.

See Also

Plugin Details

Severity: High

ID: 5611

File Name: 5611.prm

Family: CGI

Published: 2010/07/22

Modified: 2016/01/15

Dependencies: 1442

Nessus ID: 47861

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 5.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C


Base Score: 7.3

Temporal Score: 6.4


Temporal Vector: CVSS3#E:U/RL:O/RC:C

Vulnerability Information

Patch Publication Date: 2010/07/09

Vulnerability Publication Date: 2010/07/09

Reference Information

CVE: CVE-2010-2539, CVE-2010-2540

BID: 41855

OSVDB: 66825, 66838