Moodle < 1.8.13 / 1.9.x < 1.9.9 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 5575

Synopsis

The remote web server is hosting a web application that is vulnerable to multiple attack vectors.

Description

The remote web server hosts Moodle, an open-source course management system. Versions of Moodle prior to 1.8.13 or 1.9.9 are potentially affected by multiple vulnerabilities :

- A persistent cross-site scripting vulnerability in the MNET access control interface. (MSA-10-0010)

- A cross-site scripting vulnerability in 'blog/index.php'. (MSA-10-0011)

- The KSES text cleaning filter may allow registered users to launch persistent cross-site scripting attacks. (MSA-10-012)

- A potential cross-site request forgery vulnerability exists in Quiz reports. (MSA-10-013)

Solution

Upgrade to Moodle version 1.8.13, 1.9.9, or later.

See Also

http://moodle.org/security

http://docs.moodle.org/en/Release_Notes#Security_issues

http://docs.moodle.org/en/Release_Notes#Security_issues_3

http://moodle.org/mod/forum/discuss.php?d=152366

http://moodle.org/mod/forum/discuss.php?d=152367

http://moodle.org/mod/forum/discuss.php?d=152368

http://moodle.org/mod/forum/discuss.php?d=152369

Plugin Details

Severity: High

ID: 5575

File Name: 5575.prm

Family: CGI

Published: 2010/06/18

Modified: 2016/12/06

Dependencies: 8683

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 6.8

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:moodle:moodle

Patch Publication Date: 2010/06/17

Vulnerability Publication Date: 2010/06/17

Reference Information

CVE: CVE-2010-2228, CVE-2010-2229, CVE-2010-2230, CVE-2010-2231

BID: 40944

OSVDB: 65634, 65635, 65636, 65637