MODx < 1.0.3 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 5522

Synopsis

The remote web server is hosting a web application that is vulnerable to multiple attack vectors.

Description

The remote web server is hosting MODx, a content management system written in PHP. The installed version of MODx is earlier than 1.0.3. Such versions are potentially affected by multiple vulnerabilities :

- A cross-site scripting vulnerability in the 'SearchHighlight' plugin. (CVE-2010-1427)

- A SQL-injection vulnerability related to WebLogin. (CVE-2010-1426)

Solution

Upgrade to MODx 1.0.3 or later.

See Also

http://jvn.jp/en/jp/JVN19774883/index.html

http://jvn.jp/en/jp/JVN46669729/index.html

http://modxcms.com/forums/index.php/topic,47759.0.html

Plugin Details

Severity: High

ID: 5522

File Name: 5522.prm

Family: CGI

Published: 2010/04/29

Modified: 2016/01/15

Dependencies: 1442

Nessus ID: 46183

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 6.8

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

Patch Publication Date: 2010/04/01

Vulnerability Publication Date: 2010/04/01

Reference Information

CVE: CVE-2010-1426, CVE-2010-1427

BID: 39310

OSVDB: 63596, 63597