AjaXplorer < 2.6 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 5506

Synopsis

The remote web server is hosting a web application that is vulnerable to multiple attack vectors.

Description

The remote web server is hosting AjaXplorer, a web-based file management application. The installed version is earlier than 2.6. Such versions are potentially affected by multiple vulnerabilities :

- A command-injection vulnerability via the 'destserver' parameter of the 'plugins/access.ssh/checkInstall.php' script.

- Unspecified input is not properly validated before being used to read files.

Solution

Upgrade to AjaXplorer 2.6 or later.

See Also

http://www.nessus.org/u?e68820e7

Plugin Details

Severity: High

ID: 5506

File Name: 5506.prm

Family: CGI

Published: 2010/04/12

Modified: 2016/01/15

Dependencies: 1442

Nessus ID: 45489

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 6.8

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

Patch Publication Date: 2010/04/04

Vulnerability Publication Date: 2010/04/04

Reference Information

BID: 39334

OSVDB: 63552, 63553