Skype < 4.2.0.155 URI Handler Security Vulnerability

medium Nessus Network Monitor Plugin ID 5362
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host is running an instant messaging application that is vulnerable to a security bypass attack.

Description

The version of Skype installed on the remote host is earlier than 4.2.0.155. Such versions are potentially affected by a flaw in the handling of specially crafted 'skype: ' URIs. An attacker, exploiting this flaw, could control certain Skype settings and possibly gain access to sensitive information.

Solution

Upgrade to Skype 4.2.0.155 or later.

See Also

http://share.skype.com/sites/garage/2010/03/10/ReleaseNotes_4.2.0.155.pdf

Plugin Details

Severity: Medium

ID: 5362

Published: 3/15/2010

Updated: 3/6/2019

Nessus ID: 45060, 45061

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 5.8

Temporal Score: 4.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3

Risk Factor: Medium

Base Score: 4.8

Temporal Score: 4.5

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

Patch Publication Date: 3/10/2010

Vulnerability Publication Date: 3/12/2010

Reference Information

BID: 38699