SilverStripe < 2.3.5 Cross-site Scripting Vulnerability

High Nessus Network Monitor Plugin ID 5329

Synopsis

The remote web server is hosting an application that is vulnerable to a cross-site scripting attack.

Description

The remote web server is hosting SilverStripe CMS. The installed version of SilverStripe is earlier than 2.3.5. Such versions are potentially affected by a persistent cross-site scripting vulnerability becase the application fails to properly sanitize user-supplied input to the 'CommenterURL' parameter in the comment posting mechanism. An attacker could exploit this flaw in order to execute arbitrary script code in a user's browser.

Solution

Upgrade to SilverStripe 2.3.5 or later.

See Also

http://archives.neohapsis.com/archives/fulldisclosure/2010-01/0450.html

http://open.silverstripe.org/wiki/ChangeLog/2.3.5

Plugin Details

Severity: High

ID: 5329

File Name: 5329.prm

Family: CGI

Published: 2010/01/26

Modified: 2016/01/15

Dependencies: 1442

Nessus ID: 44332

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 6.8

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

Patch Publication Date: 2010/01/22

Vulnerability Publication Date: 2010/01/22

Reference Information

CVE: CVE-2010-1593

BID: 37923