phpMyAdmin < 2.11.10 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 5304


The remote web server contains a PHP application that is vulnerable to multiple attack vectors.


The remote web server is running a version of phpMyAdmin earlier than 2.11.10. Such versions are potentially affected by multiple vulnerabilities :

- A cross-site request forgery attack because the application uses the 'unserialize()' PHP function on potentially unsafe data in the setup script.(CVE-2009-4605)

- An insecure file creation and deletion vulnerability due to the way phpMyAdmin creates temporary files.


Upgrade to phpMyAdmin 2.11.10 or later.

See Also

Plugin Details

Severity: High

ID: 5304

File Name: 5304.prm

Family: CGI

Published: 2010/01/20

Modified: 2016/03/02

Dependencies: 9102

Nessus ID: 44324

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C


Base Score: 7.3

Temporal Score: 6.8


Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:phpmyadmin:phpmyadmin

Patch Publication Date: 2010/01/15

Vulnerability Publication Date: 2010/01/15

Exploitable With

Core Impact

Reference Information

CVE: CVE-2008-7251, CVE-2008-7252, CVE-2009-4605

BID: 37861, 37826

OSVDB: 61859, 61860, 61861