OpenX < 2.8.3 Authentication-Bypass

High Nessus Network Monitor Plugin ID 5285

Synopsis

The remote web server is vulnerable to an authentication bypass attack.

Description

The remote web server is hosting OpenX, a web-based ad server. The installed version is earlier than 2.8.3. Such versions are potentially affected by an authentication bypass vulnerability because the application allows anonymous access to the administrative interface.

Solution

Upgrade to OpenX 2.8.3 or later.

See Also

http://blog.openx.org/12/security-matters-2

Plugin Details

Severity: High

ID: 5285

File Name: 5285.prm

Family: CGI

Published: 2009/12/28

Modified: 2016/01/21

Dependencies: 1442

Nessus ID: 43864

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 7.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:U/RC:ND

CVSSv3

Base Score: 7.3

Temporal Score: 7.1

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:U/RC:X

Vulnerability Information

Patch Publication Date: 2009/12/23

Vulnerability Publication Date: 2009/12/22

Reference Information

CVE: CVE-2009-4830

BID: 37457

OSVDB: 61300