Moodle < 1.8.11 / 1.9.x < 1.9.7 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 5257

Synopsis

The remote web server is hosting a web application that is vulnerable to multiple attack vectors.

Description

The version of Moodle installed on the remote host is potentially vulnerable to multiple flaws.

- Multiple cross-site request forger issues. (MSA-09-0022)

- User account disclosure in LAMS module. (MSA-09-0023)

- Insufficient access control may allow unauthorized users to view glossary entries. (MSA-09-0024)

- Invalid application access control in MNET interface could allow execution of any MNET function from all registered remote servers. (MSA-09-0026)

- Login information can be sent unsecured even when a site is configured to use SSL for logins. (MSA-09-0027)

- A SQL injection issue in the SCORM module. (MSA-09-0031)

Solution

Upgrade to Moodle version 1.8.11, 1.9.7, or later.

See Also

http://moodle.org/security

Plugin Details

Severity: High

ID: 5257

File Name: 5257.prm

Family: CGI

Published: 2009/12/09

Modified: 2016/01/15

Dependencies: 8683

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 6.8

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:moodle:moodle

Patch Publication Date: 2009/12/08

Vulnerability Publication Date: 2009/12/08

Reference Information

CVE: CVE-2009-4297, CVE-2009-4298, CVE-2009-4299, CVE-2009-4300, CVE-2009-4301, CVE-2009-4302, CVE-2009-4303, CVE-2009-4304, CVE-2009-4305

BID: 37244