MapServer < 4.10.5/5.2.3/5.4.2 Integer Overflow Vulnerability

High Nessus Network Monitor Plugin ID 5210


The remote web server contains a CGI application that is vulnerable to a remote code execution attack.


The remote web server is running a version of MapServer earlier than 4.10.5 / 5.2.3 / 5.4.2. Such versions are potentially affected by an integer-overflow vulnerability when the application handles large HTTP requests containing specially crafted 'Content-Length' values.


Upgrade to MapServer 4.10.5, 5.2.3, or 5.4.2.

See Also

Plugin Details

Severity: High

ID: 5210

File Name: 5210.prm

Family: CGI

Published: 2009/10/27

Modified: 2016/01/22

Dependencies: 1442

Nessus ID: 42262

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:ND


Base Score: 7.3

Temporal Score: 6.4


Temporal Vector: CVSS3#E:U/RL:O/RC:X

Vulnerability Information

Patch Publication Date: 2009/07/23

Vulnerability Publication Date: 2009/10/22

Reference Information

CVE: CVE-2009-0840

BID: 36802