MapServer < 4.10.5/5.2.3/5.4.2 Integer Overflow Vulnerability

High Nessus Network Monitor Plugin ID 5210

Synopsis

The remote web server contains a CGI application that is vulnerable to a remote code execution attack.

Description

The remote web server is running a version of MapServer earlier than 4.10.5 / 5.2.3 / 5.4.2. Such versions are potentially affected by an integer-overflow vulnerability when the application handles large HTTP requests containing specially crafted 'Content-Length' values.

Solution

Upgrade to MapServer 4.10.5, 5.2.3, or 5.4.2.

See Also

http://trac.osgeo.org/mapserver/browser/tags/rel-5-4-2/mapserver/HISTORY.TXT

Plugin Details

Severity: High

ID: 5210

File Name: 5210.prm

Family: CGI

Published: 2009/10/27

Modified: 2016/01/22

Dependencies: 1442

Nessus ID: 42262

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 6.4

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:ND

CVSSv3

Base Score: 7.3

Temporal Score: 6.4

Vector: CVSS3#AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:U/RL:O/RC:X

Vulnerability Information

Patch Publication Date: 2009/07/23

Vulnerability Publication Date: 2009/10/22

Reference Information

CVE: CVE-2009-0840

BID: 36802