phpMyAdmin < 2.11.9.6 / 3.x < 3.2.2.1 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 5209

Synopsis

The remote web server contains a PHP application that is vulnerable to multiple attack vectors.

Description

The remote web server is running a version of phpMyAdmin prior to 2.11.9.6, or 3.x prior to 3.2.2.1. Such versions are potentially affected by multiple issues :

- A cross-site scripting (XSS) flaw exists which allows remote attackers to inject arbitrary web script or HTML via a crafted name for a MySQL table. (CVE-2009-3696)
- A SQL injection flaw affects the PDF schema generator functionality. Specifically, this flaw allows remote attackers to execute arbitrary SQL commands via unspecified interface parameters. (CVE-2009-3697)

Solution

Upgrade to phpMyAdmin 2.11.9.6 or 3.2.2.1 or later.

See Also

http://freshmeat.net/projects/phpmyadmin/releases/306667

Plugin Details

Severity: High

ID: 5209

Family: CGI

Published: 2009/10/15

Modified: 2018/09/16

Dependencies: 9102

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 6.8

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:phpmyadmin:phpmyadmin

Patch Publication Date: 2009/10/12

Vulnerability Publication Date: 2009/10/12

Reference Information

CVE: CVE-2009-3696, CVE-2009-3697

BID: 36658