Interchange Search Request Information Disclosure

Medium Nessus Network Monitor Plugin ID 5180

Synopsis

The remote web server is affected by an information-disclosure vulnerability.

Description

The remote web server is running Interchange, a web-based application server. The installed version is potentially affected by an information disclosure vulnerability. It is possible to remotely query any table configured withing Interchange by using a specially crafted search request because the application fails to limit which tables can be searched on.

Solution

Upgrade to Interchange 5.7.2, 5.6.2, or 5.4.4.

See Also

http://www.icdevgroup.org/i/dev/news?mv_arg=00038

http://ftp.icdevgroup.org/interchange/5.6/ANNOUNCEMENT-5.6.2.txt

Plugin Details

Severity: Medium

ID: 5180

File Name: 5180.prm

Family: CGI

Published: 2009/09/21

Modified: 2016/01/21

Dependencies: 1442

Nessus ID: 41056

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5

Temporal Score: 4.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:N/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 5.3

Temporal Score: 4.9

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

Patch Publication Date: 2009/09/17

Vulnerability Publication Date: 2009/09/17

Reference Information

BID: 36452