MyBB < 1.4.9 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 5179

Synopsis

The remote web server is running a PHP application that is vulnerable to multiple attack vectors.

Description

The remote web server is running a version of MyBB earlier than 1.4.9. Such versions are potentially affected by multiple issues :

- A SQL injection vulnerability in avatar extension checking and validating. (Bug 464)

- It is possible to copy another users name and put a zero-width space somewhere in it. (Bug 418)

Solution

Upgrade to MyBB 1.4.9 or later.

See Also

http://blog.mybboard.net/2009/09/21/mybb-1-4-9-released-security-update

Plugin Details

Severity: High

ID: 5179

Family: CGI

Published: 2009/09/21

Modified: 2016/01/15

Dependencies: 1442

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 6.8

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

Patch Publication Date: 2009/09/21

Vulnerability Publication Date: 2009/09/21

Reference Information

BID: 36463