Horde < 3.3.4 / 3.3.5 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 5171

Synopsis

The remote web server contains a PHP application that is vulnerable to multiple attack vectors.

Description

The version of Horde, Horde Groupware, or Horde Groupware Webmail Edition installed on the remote host is potentially affected by multiple issues :

- A vulnerability in the form library that allows the overwriting of arbitrary local files, subject to the permissions of the web server user. This issue occurs only when the application uses image form fields such as Turba H3 or Ansel.

- Two cross-site scripting vulnerabilities in the preference system and the MIME viewer library.

Solution

Upgrade to Horde version 3.2.5 / 3.3.5 or later.

See Also

http://marc.info/?l=horde-announce&amp;m=125292339907481&amp;w=2

Plugin Details

Severity: High

ID: 5171

Family: CGI

Published: 2009/09/14

Modified: 2016/01/15

Dependencies: 1442

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 6.8

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

Patch Publication Date: 2009/09/14

Vulnerability Publication Date: 2009/09/14

Reference Information

BID: 36382