FlexCMS < 3.0 'CookieUsername' Parameter SQL Injection (deprecated)

High Nessus Network Monitor Plugin ID 5144

Synopsis

The remote host is vulnerable to a SQL injection attack.

Description

The remote host is running FlexCMS, a content management system written in PHP. The installed version of FlexCMS is earlier than 3.0. Such versions are potentially affected by a SQL injection vulnerability in the 'CookieUsername' cookie parameter. An attacker, exploiting this flaw, may be able to compromise the application. Note, that this requires magic_quotes_gpc to be turned off.

Solution

Upgrade to FlexCMS 3.0 or later.

See Also

http://packetstormsecurity.org/0908-exploits/flexcms25-sql.txt

http://www.packetstormsecurity.org/0908-exploits/flexcms25-sql.txt

Plugin Details

Severity: High

ID: 5144

Family: CGI

Published: 2009/08/31

Modified: 2016/01/21

Dependencies: 1442

Nessus ID: 40824

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 7.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:U/RC:ND

CVSSv3

Base Score: 7.3

Temporal Score: 7.1

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:U/RC:X

Vulnerability Information

Patch Publication Date: 2009/04/01

Vulnerability Publication Date: 2009/08/31

Reference Information

BID: 36179