Pidgin < 2.5.9 Buffer Overflow

high Nessus Network Monitor Plugin ID 5137

Synopsis

The remote host is affected by a buffer overflow vulnerability.

Description

The remote host is running Pidgin 2.5.9. Such versions reportedly trigger an memcpy to an invalid location in memory when receiving two consecutive specially crafted SLP message.

Solution

Upgrade to Pidgin 2.5.9 or later.

See Also

http://www.coresecurity.com/content/libpurple-arbitrary-write

http://archives.neohapsis.com/archives/bugtraq/2009-08/0158.html

http://pidgin.im/news/security/?id=34

Plugin Details

Severity: High

ID: 5137

Published: 8/21/2009

Updated: 3/6/2019

Nessus ID: 40663

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3.0

Base Score: 7.3

Temporal Score: 6.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:pidgin:pidgin:*:*:*:*:*:*:*:*

Patch Publication Date: 8/18/2009

Vulnerability Publication Date: 8/18/2009

Exploitable With

Core Impact

Reference Information

CVE: CVE-2009-2694

BID: 36071