WordPress < 2.8.4 Security Bypass Vulnerability

Medium Nessus Network Monitor Plugin ID 5126

Synopsis

The remote host is affected by a security bypass vulnerability.

Description

The remote host is running a version of WordPress earlier than 2.8.4. Such versions are potentially affected by a flaw in the 'reset_password()' function of the 'wp-login.php' script which allows an attacker to reset the password for the first account without a key in the database (usually the admin account).

Solution

Upgrade to WordPress 2.8.4, or later.

See Also

http://archives.neohapsis.com/archives/fulldisclosure/2009-08/0114.html

http://core.trac.wordpress.org/changeset/11798

http://wordpress.org/development/2009/08/2-8-4-security-release

Plugin Details

Severity: Medium

ID: 5126

File Name: 5126.prm

Family: CGI

Published: 2009/08/12

Modified: 2016/02/05

Dependencies: 9035

Nessus ID: 40577, 40578

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 6.4

Temporal Score: 5.3

Vector: CVSS2#AV:N/AC:L/Au:N/C:N/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 6.4

Temporal Score: 5.9

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

Patch Publication Date: 2009/08/12

Vulnerability Publication Date: 2009/08/10

Reference Information

CVE: CVE-2009-2762

BID: 36014