WordPress < 2.8.2 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 5106


The remote server is hosting an outdated installation of WordPress that is vulnerable to multiple attack vectors.


The remote host is running a version of WordPress earlier than 2.8.2. Such versions are reportedly affected by a cross-site scripting vulnerability. In particular, the 'uri' parameter of the 'wp-comments-post.php' script is not sufficiently sanitized. An attacker, exploiting this flaw, would be able to inject script code which would be executed within the browser. In order to exploit this flaw, the attacker would need to be able to entice an unsuspecting user into opening a specially formatted URI.


Upgrade to WordPress 2.8.1, or later.

See Also


Plugin Details

Severity: Medium

ID: 5106

Family: CGI

Published: 2007/07/29

Modified: 2016/01/21

Dependencies: 9035

Risk Information

Risk Factor: Medium


Base Score: 5.8

Temporal Score: 4.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C


Base Score: 4.8

Temporal Score: 4.5


Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

Patch Publication Date: 2007/07/23

Vulnerability Publication Date: 2007/07/23

Reference Information

BID: 35755, 35797