MediaWiki 1.14.0 / 1.15.0 Cross-Site Scripting Vulnerability

Medium Nessus Network Monitor Plugin ID 5097

Synopsis

The remote web server is running a PHP application that is affected by a cross-site scripting vulnerability.

Description

The remote web server is running MediaWiki 1.14.0 or 1.15.0. These versions reportedly fail to properly supply user-supplied input to the 'ip' parameter of the 'Special: Blocks' page. An attacker could exploit this flaw to launch cross-site scripting attacks.

Solution

Upgrade to MediaWiki 1.14.1/1.15.1 or later.

See Also

http://lists.wikimedia.org/pipermail/mediawiki-announce/2009-July/000087.html

Plugin Details

Severity: Medium

ID: 5097

File Name: 5097.prm

Family: CGI

Published: 2004/08/18

Modified: 2016/11/23

Dependencies: 1442

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5.8

Temporal Score: 4.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 4.8

Temporal Score: 4.5

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Reference Information

CVE: CVE-2009-4589

BID: 35662

OSVDB: 55824