WordPress < 2.8.1 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 5096


The remote web server is running a PHP application that is vulnerable to multiple attack vectors.


The remote host is running a version of WordPress earlier than 2.8.1. Such versions are reportedly affected by multiple vulnerabilities :

- A username enumeration weakness caused by the application displaying different responses to login requests depending on the existence of the supplied username. (CVE-2009-2334)

- A security-bypass vulnerability in the 'wp-admin/admin.php' script when it is called with the 'pages' parameter set to a plug-in configuration page. An authenticated attacker could exploit this to gain access to configuration scripts. (CVE-2009-2335)


Upgrade to WordPress 2.8.1, or later.

See Also


Plugin Details

Severity: Medium

ID: 5096

Family: CGI

Published: 2004/08/18

Modified: 2018/07/11

Dependencies: 9035

Risk Information

Risk Factor: Medium


Base Score: 6.5

Temporal Score: 5.4

Vector: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C


Base Score: 6.3

Temporal Score: 5.9


Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:wordpress:wordpress

Reference Information

CVE: CVE-2009-2334, CVE-2009-2335, CVE-2009-2336

BID: 35581, 35584