Simple Machines < 1.1.9 / 2.0.0 RC1 XSS (deprecated)

Medium Nessus Network Monitor Plugin ID 5039

Synopsis

The remote host is vulnerable to a cross-site scripting attack.

Description

The remote host is running Simple Machines Forum. The installed version is earlier than 1.1.9 / 2.0.0 RC1-1. Such versions fail to properly sanitize user-supplied images identified as 'image/bmp' MIME types. Successful exploitation would result in an attacker executing script code within the browsers of other users.

Solution

Upgrade to Simple Machines Forum 1.1.9 / 2.0.0 RC1-1

See Also

http://www.securityfocus.com/archive/1/503867/30/0/threaded

Plugin Details

Severity: Medium

ID: 5039

Family: CGI

Published: 2004/08/18

Modified: 2016/01/21

Dependencies: 1442

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5.8

Temporal Score: 4.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 4.8

Temporal Score: 4.5

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Reference Information

BID: 35130