SquirrelMail < 1.4.18 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 5037


The remote host is vulnerable to multiple attack vectors.


The remote host is running SquirrelMail, a web-based email client. The installed version of SquirrelMail is affected by multiple vulnerabilities :

- Multiple cross-site scripting vulnerabilities.

- A code-injection vulnerability affects the 'map_yp_alias' function which an attacker could exploit to execute arbitrary code subject to the privileges of the web server.

- Multiple session-fixation issues could allow an attacker to steal an unsuspecting user's session.


Upgrade to SquirrelMail 1.4.18 or newer.

See Also


Plugin Details

Severity: High

ID: 5037

Family: CGI

Published: 2004/08/18

Updated: 2019/03/06

Dependencies: 1442

Nessus ID: 38793, 38794

Risk Information

Risk Factor: High

CVSS v2.0

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3.0

Base Score: 7.3

Temporal Score: 6.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:squirrelmail:squirrelmail

Reference Information

CVE: CVE-2009-1580, CVE-2009-1581, CVE-2009-1578, CVE-2009-1579

BID: 34916