SquirrelMail < 1.4.18 Multiple Vulnerabilities

high Nessus Network Monitor Plugin ID 5037

Synopsis

The remote host is vulnerable to multiple attack vectors.

Description

The remote host is running SquirrelMail, a web-based email client. The installed version of SquirrelMail is affected by multiple vulnerabilities :

- Multiple cross-site scripting vulnerabilities.

- A code-injection vulnerability affects the 'map_yp_alias' function which an attacker could exploit to execute arbitrary code subject to the privileges of the web server.

- Multiple session-fixation issues could allow an attacker to steal an unsuspecting user's session.

Solution

Upgrade to SquirrelMail 1.4.18 or newer.

See Also

http://www.squirrelmail.org/security/issue/2009-05-10

Plugin Details

Severity: High

ID: 5037

Family: CGI

Published: 8/18/2004

Updated: 3/6/2019

Nessus ID: 38793, 38794

Risk Information

CVSS v2

Risk Factor: High

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3

Risk Factor: High

Base Score: 7.3

Temporal Score: 6.8

Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:squirrelmail:squirrelmail:*:*:*:*:*:*:*:*

Reference Information

CVE: CVE-2009-1580, CVE-2009-1581, CVE-2009-1578, CVE-2009-1579

BID: 34916