Moodle 1.6.x < 1.6.9 / 1.7.x < 1.7.7 / 1.8.x < 1.8.8 / 1.9.x < 1.9.4 Multiple Vulnerabilities
High Nessus Network Monitor Plugin ID 4924
SynopsisThe remote web server is hosting a web application that is vulnerable to multiple attack vectors.
DescriptionThe version of Moodle installed on the remote host is vulnerable to a number of flaws. First, the server is vulnerable to a cross-site scripting (XSS) flaw. An attacker exploiting this flaw would be able to execute arbitrary code within the browser of unsuspecting users. The remote host is vulnerable to a cross-site request forgery (CSRF) flaw that could allow remote users to execute commands on the behalf of logged in users. Finally, there are several information disclosure flaws that may allow an attacker the ability to gain access to confidential data.
SolutionUpgrade to version 1.6.9, 1.7.7, 1.8.8, 1.9.4 or higher.