WordPress < 2.6.5 'feed.php' XSS

Medium Nessus Network Monitor Plugin ID 4775

Synopsis

The remote web server contains a PHP application that is affected by a cross-site scripting vulnerability.

Description

The version of WordPress installed on the remote host fails to completely sanitize input to the the 'Host' request header before using it in the 'self_link()' function in 'wp-includes/feed.php' to generate dynamic HTML output. An attacker may be able to leverage this to inject arbitrary HTML and script code into a user's browser to be executed within the security context of the affected site.

Solution

Upgrade to WordPress 2.6.5, or later.

See Also

http://wordpress.org/development/2008/11/wordpress-265

http://www.securityfocus.com/archive/1/498652/30/0/threaded

Plugin Details

Severity: Medium

ID: 4775

Family: CGI

Published: 2008/12/02

Modified: 2018/07/11

Dependencies: 9035

Nessus ID: 34994

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5.8

Temporal Score: 4.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 4.8

Temporal Score: 4.5

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:wordpress:wordpress

Reference Information

CVE: CVE-2008-5278

BID: 32476