WordPress 2.x < 2.6 'press-this.php' XSS

Medium Nessus Network Monitor Plugin ID 4587

Synopsis

The remote host is vulnerable to a Cross-Site Scripting (XSS) attack.

Description

The version of WordPress installed on the remote host is vulnerable to a cross-site scripting flaw due to the way that it parses user-supplied data to the 'press-this.php' script. An attacker exploiting this flaw would need to be able to convince a WordPress user to open a malicious URI. Successful exploitation would result in attacker code being run in the browser.

Solution

Upgrade to WordPress 2.6, or later.

See Also

http://trac.wordpress.org/ticket/7220

Plugin Details

Severity: Medium

ID: 4587

File Name: 4587.prm

Family: CGI

Published: 2004/08/18

Modified: 2016/01/21

Dependencies: 9035

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5.8

Temporal Score: 4.8

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 4.8

Temporal Score: 4.5

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Reference Information

BID: 30238