WordPress < 2.5.1 Crafted Cookie Authentication Bypass

High Nessus Network Monitor Plugin ID 4488

Synopsis

The remote host is vulnerable to a flaw that allows authenticated users to gain administrative access.

Description

The version of WordPress installed on the remote host is vulnerable to a flaw in the way that it handles cookies. Specifically, an attacker with the ability to create specific accounts would be able to use the flaw in the cookie handler to gain administrative access to the application.

Solution

Upgrade to WordPress 2.5.1, or later.

See Also

http://www.cl.cam.ac.uk/users/sjm217/advisories/wordpress-cookie-integrity.txt

Plugin Details

Severity: High

ID: 4488

Family: CGI

Published: 2008/04/28

Modified: 2018/07/11

Dependencies: 9035

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 6.8

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:wordpress:wordpress

Reference Information

CVE: CVE-2008-1930

BID: 28935