phpMyAdmin < 2.11.5 SQLi

Medium Nessus Network Monitor Plugin ID 4407

Synopsis

The remote web server contains a PHP application that is affected by a SQL injection attack.

Description

The remote host is running phpMyAdmin, a web interface for administering MySQL database servers. This version of phpMyAdmin is vulnerable to a SQL injection attack via the '$_REQUEST' variable. An attacker exploiting this flaw would need to send a specially formatted cookie containing the attacker's SQL commands. An attacker exploiting this flaw would be able to execute arbitrary SQL commands on the database server utilized by phpMyAdmin.

Solution

Upgrade to version 2.11.5 or higher.

See Also

http://www.phpmyadmin.net

Plugin Details

Severity: Medium

ID: 4407

File Name: 4407.prm

Family: CGI

Published: 2008/03/03

Modified: 2016/03/02

Dependencies: 9102

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 6.8

Temporal Score: 5.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 5.6

Temporal Score: 5.2

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:phpmyadmin:phpmyadmin

Reference Information

CVE: CVE-2008-1149

BID: 28068