Skype Technologies < 3.6.0.216 skype4com URI Handler Remote Heap Corruption

medium Nessus Network Monitor Plugin ID 4310
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote Skype client is affected by a buffer overflow.

Description

The version of Skype installed on the remote host is vulnerable to a heap overflow vulnerability in the skype4com URI handler. A remote attacker would have to convince a user to click on a specially-crafted Skype URL to exploit this flaw.

Solution

Upgrade to version 3.6.0.216 or higher.

See Also

http://www.zerodayinitiative.com/advisories/ZDI-07-070.html

Plugin Details

Severity: Medium

ID: 4310

Published: 12/10/2007

Updated: 3/6/2019

Dependencies: 1735, 8314

Nessus ID: 29250

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 6.8

Temporal Score: 5

Vector: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:U/RL:OF/RC:C

CVSS v3

Risk Factor: Medium

Base Score: 5.6

Temporal Score: 4.9

Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:U/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:skype_technologies:skype:*:*:*:*:*:*:*:*

Reference Information

CVE: CVE-2007-5989

BID: 26748