WordPress < 2.1.4 'admin-ajax.php' SQLi

Medium Nessus Network Monitor Plugin ID 3995

Synopsis

The remote host is vulnerable to a SQL injection attack.

Description

The version of WordPress installed on the remote host is vulnerable to a SQL injection attack.

An attacker exploiting this flaw would only need to be able to send data to the 'wp-admin/admin-ajax.php' script. Successful exploitation would result in the attacker executing SQL commands on the remote database server

Solution

Upgrade to WordPress 2.1.4, or later.

See Also

http://wordpress.org

Plugin Details

Severity: Medium

ID: 3995

Family: CGI

Published: 2007/05/21

Modified: 2016/11/23

Dependencies: 9035

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5.8

Temporal Score: 4.8

Vector: CVSS2#AV:A/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 6.3

Temporal Score: 5.9

Vector: CVSS3#AV:A/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Reference Information

CVE: CVE-2007-2821

BID: 24076