GroupWise < 7.0.0 SP2 WebAccess GWINTER.exe Base64 Decoding Overflow

medium Nessus Network Monitor Plugin ID 3971
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host is vulnerable to a buffer overflow.

Description

The remote host is running a version of GroupWise WebAccess from Novell that fails to sanitize HTTP authentication requests. An overly long request will generate an overflow on the remote WebAccess server. An attacker exploiting this flaw would only need to be able to connect to the service and send an HTTP basic authentication request. Successful exploitation would result in the attacker executing arbitrary code.

Solution

Upgrade to version 7.0.0 SP2 or higher.

See Also

http://www.zerodayinitiative.com/advisories/ZDI-07-015.html

Plugin Details

Severity: Medium

ID: 3971

Family: CGI

Published: 4/20/2007

Updated: 3/6/2019

Dependencies: 1442, 2731

Risk Information

CVSS v2

Risk Factor: Medium

Base Score: 5.8

Temporal Score: 4.8

Vector: CVSS2#AV:A/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSS v3

Risk Factor: Medium

Base Score: 6.3

Temporal Score: 5.9

Vector: CVSS:3.0/AV:A/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS:3.0/E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:2.3:a:novell:groupwise:*:*:*:*:*:*:*:*

Exploitable With

CANVAS (CANVAS)

Reference Information

CVE: CVE-2007-2171

BID: 23556