WordPress < 2.1.3 'xmlrpc.php' SQLi

Medium Nessus Network Monitor Plugin ID 3959

Synopsis

The remote host is vulnerable to a SQL Injection attack.

Description

The version of WordPress installed on the remote host is vulnerable to a SQL injection attack. An attacker exploiting this flaw would need to have the ability to authenticate to WordPress. Upon authentication, the attacker would send a malformed query that, when processed, would execute arbitrary SQL commands on the WordPress database.

Solution

Upgrade to WordPress 2.1.3, or later.

See Also

http://wordpress.org

Plugin Details

Severity: Medium

ID: 3959

Family: CGI

Published: 2007/04/04

Modified: 2018/07/11

Dependencies: 9035

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5.8

Temporal Score: 4.8

Vector: CVSS2#AV:A/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 6.3

Temporal Score: 5.9

Vector: CVSS3#AV:A/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:wordpress:wordpress

Reference Information

CVE: CVE-2007-1897

BID: 23294