Horde < 3.1.4 NLS.php new_lang Parameter XSS

Medium Nessus Network Monitor Plugin ID 3950

Synopsis

The remote web server contains a PHP application that is vulnerable to a cross-site scripting attack.

Description

The remote web server contains a PHP application that is vulnerable to a cross-site scripting attack.

The version of Horde installed on the remote host fails to sanitize input to the 'new_lang' parameter before using it in the 'framework/NLS/NLS.php' script to generate dynamic content. An unauthenticated remote attacker may be able to leverage this issue to inject arbitrary HTML or script code into a user's browser to be executed within the security context of the affected site.

Solution

Upgrade to version 3.1.4 or higher.

See Also

http://archives.neohapsis.com/archives/bugtraq/2007-03/0181.html

http://lists.horde.org/archives/announce/2007/000315.html

Plugin Details

Severity: Medium

ID: 3950

File Name: 3950.prm

Family: CGI

Published: 2007/03/15

Modified: 2016/02/05

Dependencies: 1442

Nessus ID: 24817

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4.3

Temporal Score: 3.6

Vector: CVSS2#AV:A/AC:M/Au:N/C:P/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 4.1

Temporal Score: 3.8

Vector: CVSS3#AV:A/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:horde:horde_application_framework

Reference Information

CVE: CVE-2007-1473

BID: 22984

OSVDB: 33084