WordPress < 2.1.2 RCE

Medium Nessus Network Monitor Plugin ID 3933

Synopsis

The remote web server contains a PHP application that is affected by a remote command execution vulnerability.

Description

The version of WordPress installed on the remote host may include a backdoor that allows an unauthenticated remote attacker to execute arbitrary code on the remote host, subject to the permissions of the web server user ID.

Solution

Upgrade to WordPress 2.1.2, or later.

See Also

http://www.securityfocus.com/archive/1/461794/30/0/threaded

http://wordpress.org/development/2007/03/upgrade-212

http://ifsec.blogspot.com/2007/03/wordpress-code-compromised-to-enable.html

Plugin Details

Severity: Medium

ID: 3933

Family: CGI

Published: 2007/03/05

Modified: 2018/09/16

Dependencies: 9035

Nessus ID: 24759

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5.8

Temporal Score: 4.8

Vector: CVSS2#AV:A/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 6.3

Temporal Score: 5.9

Vector: CVSS3#AV:A/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:wordpress:wordpress

Reference Information

CVE: CVE-2007-1277

BID: 22797