WordPress < 2.1 Pingback Information Disclosure

Medium Nessus Network Monitor Plugin ID 3890

Synopsis

The remote host is vulnerable to multiple attack vectors.

Description

The version of WordPress installed on the remote host fails to sanitize the 'sourceURI' before passing it to the 'wp_remote_fopen()' function when processing pingbacks. An unauthenticated remote attacker can leverage this issue to determine the existence of local files and possibly even to view parts of those files, subject to the permissions of the web server user ID. In addition, the version is also reportedly susceptible to a denial of service attack because it allows an anonymous attacker to cause a server to fetch arbitrary URLs without limits.

Solution

Upgrade to WordPress 2.1, or later.

See Also

http://www.securityfocus.com/archive/1/458003/30/0/threaded

http://comox.textdrive.com/pipermail/wp-svn/2007-January/002387.html

http://wordpress.org

Plugin Details

Severity: Medium

ID: 3890

Family: CGI

Published: 2007/01/24

Modified: 2018/09/16

Dependencies: 9035

Nessus ID: 24237

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5.8

Temporal Score: 4.8

Vector: CVSS2#AV:A/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 6.3

Temporal Score: 5.9

Vector: CVSS3#AV:A/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Reference Information

BID: 22220