phpMyFAQ < 1.6.8 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 3880

Synopsis

The remote web server contains a script that is vulnerable to a SQL injection attack.

Description

The remote host is running phpMyFAQ, a web-based Frequently-Asked-Questions (FAQ) application. This version of phpMyFAQ is vulnerable to a remote SQL injection attack. An attacker exploiting this flaw would send a specially crafted HTTP request to the application. Upon parsing the request, the server would be manipulated into running commands embedded within the request. A successful attack would give the attacker the ability to view data, modify data and potentially execute systems commands with the permission of the web server. In addition, the host is vulnerable to a flaw where users can bypass authentication and gain administrative access to the application. Successful exploitation would lead to the compromise of confidentiality, integrity, and availability on the remote machine.

Solution

Upgrade to version 1.6.8 or higher.

See Also

http://www.phpmyfaq.de/advisory_2006-12-15.php

Plugin Details

Severity: Medium

ID: 3880

Family: CGI

Published: 2007/01/08

Modified: 2016/01/21

Dependencies: 1442

Nessus ID: 24001

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5.8

Temporal Score: 4.8

Vector: CVSS2#AV:A/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 6.3

Temporal Score: 5.9

Vector: CVSS3#AV:A/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:phpmyfaq:phpmyfaq

Reference Information

CVE: CVE-2006-6912, CVE-2006-6913

BID: 21945, 21944