phpBB < 2.0.22 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 3874


The remote host is vulnerable to multiple attack vectors.


According to its banner, the remote host is running a version of phpBB that fails to sanitize user-supplied input. The details of several of these flaws is unknown; however, it is known that one of the vulnerabilities is an HTML injection flaw. This can enable an attacker to cause arbitrary HTML and script code to be executed in a user's browser within the context of the affected site.


Upgrade to version 2.0.22 or higher.

See Also;t=489624

Plugin Details

Severity: Medium

ID: 3874

File Name: 3874.prm

Family: CGI

Published: 2006/12/29

Modified: 2016/01/21

Dependencies: 1442

Risk Information

Risk Factor: Medium


Base Score: 5.8

Temporal Score: 4.8

Vector: CVSS2#AV:A/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C


Base Score: 6.3

Temporal Score: 5.9


Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:phpbb_group:phpbb

Reference Information

CVE: CVE-2006-4758, CVE-2006-6421, CVE-2006-6839, CVE-2006-6840, CVE-2006-6841

BID: 22001, 21806