phpMyAdmin < 2.9.1-rc1 Multiple Vulnerabilities

Medium Nessus Network Monitor Plugin ID 3756

Synopsis

The remote web server contains a PHP application that is affected by multiple vulnerabilities.

Description

Versions of phpMyAdmin prior to 2.9.1-rc1 are affected by the following vulnerabilities :

- A series of cross-site request forgery (CSRF) flaws that allow remote attackers to perform unauthorized actions as another user. Specifically, this flaw affects the files 'libraries/common.lib.php', 'session.inc.php', and 'url_generating.lib.php' and is leveraged by (1) directly setting a token in the URL though dynamic variable evaluation and (2) unsetting arbitrary variables via the '_REQUEST' array. (CVE-2006-5116)
- Insufficient access control in the phpMyAdmin libraries directory under the web root. Exploiting this flaw would allow a remote attacker to obtain sensitive information via direct requests for certain files. (CVE-2006-5117)

Solution

Upgrade to version 2.9.1-rc1 or higher.

See Also

http://www.phpmyadmin.net/home_page/downloads.php?relnotes=0

Plugin Details

Severity: Medium

ID: 3756

File Name: 3756.prm

Family: CGI

Published: 2006/09/28

Modified: 2016/03/02

Dependencies: 9102

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5.4

Temporal Score: 4.5

Vector: CVSS2#AV:A/AC:M/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 5

Temporal Score: 4.7

Vector: CVSS3#AV:A/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:phpmyadmin:phpmyadmin

Reference Information

CVE: CVE-2006-5116, CVE-2006-5117

BID: 20253, 21421