Geeklog FCKeditor < 1.4.0sr4 Arbitrary File Upload

Medium Nessus Network Monitor Plugin ID 3677

Synopsis

The remote web server contains a PHP application that is affected by an arbitrary file upload vulnerability.

Description

The remote host is running Geeklog, an open-source weblog powered by PHP and MySQL. The version of Geeklog installed on the remote host includes an older version of FCKeditor that is enabled by default and allows an unauthenticated attacker to upload arbitrary files containing PHP code, and then to execute them subject to the privileges of the web server user ID.

Solution

Upgrade to Geeklog 1.4.0sr4 or higher.

See Also

http://www.milw0rm.com/exploits/1964

http://www.geeklog.net/article.php/exploit-for-fckeditor-filemanager

http://www.geeklog.net/article.php/geeklog-1.4.0sr4

Plugin Details

Severity: Medium

ID: 3677

Family: CGI

Published: 2006/07/05

Modified: 2018/07/11

Dependencies: 1442

Nessus ID: 21780

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5.1

Temporal Score: 4.8

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:U/RC:C

CVSSv3

Base Score: 5.6

Temporal Score: 5.4

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:U/RC:C

Vulnerability Information

CPE: cpe:/a:geeklog:geeklog

Reference Information

CVE: CVE-2006-3362

BID: 18767, 19072