Yahoo! Messenger <= 7.5.0.184 Multiple Vulnerabilities

medium Nessus Network Monitor Plugin ID 3665
New! Plugin Severity Now Using CVSS v3

The calculated severity for Plugins has been updated to use CVSS v3 by default. Plugins that do not have a CVSS v3 score will fall back to CVSS v2 for calculating severity. Severity display preferences can be toggled in the settings dropdown.

Synopsis

The remote host is vulnerable to multiple attack vectors.

Description

The remote host is running a version of Yahoo! Messenger that is reported vulnerable to a remote overflow. An attacker exploiting this flaw would craft a malicious message that included non-ASCII characters. The attacker would then send the malformed message to another Yahoo! Messenger user. When the user received the malicious message, the overflow would be triggered and the application would crash. In addition, the remote client is vulnerable to a flaw where remote users can initiate a browser connection by sending a malformed string to the Yahoo! Messenger Client.

Solution

Upgrade or patch according to vendor recommendations.

See Also

http://messenger.yahoo.com

Plugin Details

Severity: Medium

ID: 3665

Published: 6/23/2006

Updated: 3/6/2019

Dependencies: 1273, 1275

Risk Information

CVSS v2

Risk Factor: Low

Base Score: 3.3

Temporal Score: 3.1

Vector: CVSS2#AV:A/AC:L/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:U/RC:ND

CVSS v3

Risk Factor: Medium

Base Score: 4.3

Temporal Score: 4.2

Vector: CVSS:3.0/AV:A/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS:3.0/E:F/RL:U/RC:X

Vulnerability Information

CPE: cpe:2.3:a:yahoo:messenger:*:*:*:*:*:*:*:*

Reference Information

CVE: CVE-2006-3298

BID: 19211, 18622