WordPress < 2.0.3 Arbitrary Code Injection

High Nessus Network Monitor Plugin ID 3647

Synopsis

The remote host is vulnerable to an arbitrary 'command insertion' flaw.

Description

The remote WordPress application is vulnerable to an arbitrary 'code injection' flaw. The application fails to sanitize cached 'username' data. An attacker exploiting this flaw would send a malformed request to the WordPress application. Successful exploitation would result in the attacker running arbitrary commands with the permission of the WordPress application.

Solution

Upgrade to WordPress 2.0.3, or later.

See Also

http://wordpress.org

Plugin Details

Severity: High

ID: 3647

File Name: 3647.prm

Family: CGI

Published: 2006/06/12

Modified: 2016/11/23

Dependencies: 9035

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 6.8

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Reference Information

CVE: CVE-2006-2702, CVE-2006-2667

BID: 18372