Woltlab Burning Board < 2.3.5 links.php cat Parameter SQL Injection

High Nessus Network Monitor Plugin ID 3631

Synopsis

The remote web server contains a script that is vulnerable to a SQL injection attack.

Description

The remote host is running Woltlab Burning Board, a web bulletin board written in PHP. This version of Burning Board is vulnerable to a remote SQL Injection attack. An attacker exploiting this flaw would send a malformed 'cat' parameter to the 'links.php' script. Succesful exploitation would result in the attacker being able to read or write confidential data. In some instances, the attacker may be able to execute arbitrary code on the remote database server.

Solution

Upgrade to version 2.3.5 or higher.

See Also

http://www.woltlab.de

Plugin Details

Severity: High

ID: 3631

Family: CGI

Published: 2006/05/25

Modified: 2016/01/21

Dependencies: 1442

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 7.1

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:U/RC:ND

CVSSv3

Base Score: 7.3

Temporal Score: 7.1

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:F/RL:U/RC:X

Vulnerability Information

CPE: cpe:/a:woltlab:burning_board

Reference Information

CVE: CVE-2006-2569, CVE-2006-3254, CVE-2006-3255, CVE-2006-3256

BID: 18423, 18597, 18077