PHP-Fusion < 6.00.308 SQL Injection

High Nessus Network Monitor Plugin ID 3622


The remote host is vulnerable to a SQL Injection attack.


According to its version number, the remote host is running a version of PHP-Fusion that suffers from a flaw within the 'messages.php' script. messages.php fails to correctly parse user-supplied data and is vulnerable to a SQL injection attack. An attacker exploiting this flaw would send a specially formed query to the script. Successful exploitation would result in the attacker being able to execute arbitrary SQL commands on the backend database server.


Upgrade to version 6.00.308 or higher.

See Also

Plugin Details

Severity: High

ID: 3622

File Name: 3622.prm

Family: CGI

Published: 2006/05/17

Modified: 2016/01/15

Dependencies: 1442

Risk Information

Risk Factor: High


Base Score: 7.5

Temporal Score: 6.2

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:F/RL:OF/RC:C


Base Score: 7.3

Temporal Score: 6.8


Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:php_fusion:php_fusion

Reference Information

CVE: CVE-2006-4673, CVE-2008-1918, CVE-2006-2459

BID: 18009, 19908, 19910, 28855

OSVDB: 25542, 28613, 44532