phpPGAds/phpAdNew < 2.0.8 Multiple Injection Vulnerabilities

Medium Nessus Network Monitor Plugin ID 3488

Synopsis

The remote host is vulnerable to HTML Injection and Cross-Site Scripting attacks.

Description

There is a flaw in the remote phpAdNew/phpPgAds PHP Ads server, a banner management and tracking system written in PHP. This version of phpAdNew is vulnerable to an HTML injection and a Cross-Site Scripting (XSS) flaw. An attacker exploiting these flaws would be able to gain access to potentially confidential data

Solution

Upgrade to version 2.0.8 or higher.

See Also

http://www.phppgads.com/one

Plugin Details

Severity: Medium

ID: 3488

Family: CGI

Published: 2006/03/27

Modified: 2016/01/21

Dependencies: 1442

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4.3

Temporal Score: 3.6

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:F/RL:OF/RC:C

CVSSv3

Base Score: 5.3

Temporal Score: 4.9

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS3#E:F/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:phppgadmin:phppgadmin

Reference Information

CVE: CVE-2006-1397

BID: 17251