WordPress < 2.0.1 Arbitrary Script Injection

Low Nessus Network Monitor Plugin ID 3435

Synopsis

The remote server is hosting an outdated installation of WordPress that is vulnerable to a script injection attack.

Description

The installed version of WordPress on the remote host will accept and execute arbitrary PHP code. This version of Wordpress is vulnerable to a flaw where a remote attacker can, by sending a malformed request, execute arbitrary code on the WordPress server.

Solution

Upgrade to WordPress 2.0.1, or later.

See Also

http://wordpress.org

Plugin Details

Severity: Low

ID: 3435

File Name: 3435.prm

Family: CGI

Published: 2006/02/15

Modified: 2016/11/23

Dependencies: 9035

Risk Information

Risk Factor: Low

CVSSv2

Base Score: 2.6

Temporal Score: 2.3

Vector: CVSS2#AV:N/AC:H/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:ND/RL:OF/RC:C

CVSSv3

Base Score: 3.7

Temporal Score: 3.6

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS3#E:X/RL:O/RC:C

Reference Information

CVE: CVE-2006-0733

BID: 16656