Xoops < 2.2.4 Multiple Vulnerabilities

High Nessus Network Monitor Plugin ID 3293

Synopsis

The remote host is vulnerable to multiple attack vectors.

Description

The version of Xoops installed on the remote host is prone to several vulnerabilities. These include HTML Injection, SQL Injection, and Directory traversal flaws. An attacker exploiting these flaws would be able to retrieve confidential data from the remote server, execute arbitrary SQL commands on the remote database server, and execute malicious code within the browser of unsuspecting users.

Solution

Upgrade to version 2.2.4 or higher.

See Also

http://www.xoops.org

Plugin Details

Severity: High

ID: 3293

Family: CGI

Published: 2005/11/14

Modified: 2018/09/16

Dependencies: 1442

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:H/RL:U/RC:ND

CVSSv3

Base Score: 7.3

Temporal Score: 7.3

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:H/RL:U/RC:X

Vulnerability Information

CPE: cpe:/a:xoops:xoops

Reference Information

CVE: CVE-2005-3680, CVE-2005-3681

BID: 15406