Moodle < 1.5.3 'datalib.php' SQLi

High Nessus Network Monitor Plugin ID 3291

Synopsis

The remote host is vulnerable to a SQL Injection attack.

Description

The remote host is running Moodle, an open-source content-management system written in PHP. This version of Moodle is vulnerable to a SQL Injection flaw. An attacker exploiting this flaw would send a malformed request to one of the affected PHP scripts. Successful exploitation would result in the attacker executing arbitrary commands against the backend SQL server. This would lead to a loss of confidential material, possible loss of database integrity, and possible loss of availability.

Solution

Upgrade to version 1.5.3 or higher.

See Also

http://security.moodle.org/mod/forum/discuss.php?d=186

Plugin Details

Severity: High

ID: 3291

Family: CGI

Published: 2005/11/14

Modified: 2018/09/16

Dependencies: 8683

Nessus ID: 20210

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:H/RL:U/RC:ND

CVSSv3

Base Score: 7.3

Temporal Score: 7.3

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:H/RL:U/RC:X

Vulnerability Information

CPE: cpe:/a:moodle:moodle

Patch Publication Date: 2005/11/10

Vulnerability Publication Date: 2005/11/10

Reference Information

CVE: CVE-2005-3648

BID: 15380