Simple PHP Blog <= 0.4.5 SQL Injection

High Nessus Network Monitor Plugin ID 3278

Synopsis

The remote host is vulnerable to a SQL Injection attack.

Description

The remote host is running Simple PHP Blog, a blog written in PHP. The version of Simple PHP Blog installed on the remote host is vulnerable to a SQL Injection flaw. An attacker exploiting this flaw would send malformed PHP queries to the application. Successful exploitation would result in the attacker executing arbitrary commands on the backend database.

Solution

No solution is known at this time.

See Also

http://www.simplephpblog.com

Plugin Details

Severity: High

ID: 3278

Family: CGI

Published: 2005/11/03

Modified: 2018/07/11

Dependencies: 1442

Risk Information

Risk Factor: High

CVSSv2

Base Score: 7.5

Temporal Score: 7.5

Vector: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:H/RL:U/RC:C

CVSSv3

Base Score: 7.3

Temporal Score: 7.3

Vector: CVSS3#AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:H/RL:U/RC:C

Vulnerability Information

CPE: cpe:/a:alexander_palmo:simple_php_blog

Reference Information

CVE: CVE-2005-3473

BID: 15283