phpMyAdmin < 2.6.4-pl3 'usesubform' Parameter Remote File Inclusion

Medium Nessus Network Monitor Plugin ID 3252

Synopsis

The remote web server contains a PHP application that is prone to information disclosure attacks.

Description

Versions of phpMyAdmin prior to 2.6.4-pl3 contain a flaw that allows attackers to read arbitrary files because of its failure to sanitize the parameter 'usesubform' before using it in several scripts.

Solution

Upgrade to phpMyAdmin 2.6.4-pl3 or later.

See Also

http://www.phpmyadmin.net/home_page/security.php?issue=PMASA-2005-4

http://securityreason.com/achievement_securityalert/24

Plugin Details

Severity: Medium

ID: 3252

Family: CGI

Published: 2005/10/11

Modified: 2018/09/16

Dependencies: 9102

Nessus ID: 19950

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 5.1

Temporal Score: 4.4

Vector: CVSS2#AV:N/AC:H/Au:N/C:P/I:P/A:P

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

CVSSv3

Base Score: 5.6

Temporal Score: 5.3

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

Temporal Vector: CVSS3#E:H/RL:O/RC:C

Vulnerability Information

CPE: cpe:/a:phpmyadmin:phpmyadmin

Reference Information

CVE: CVE-2005-2869, CVE-2005-3300, CVE-2005-3301, CVE-2005-3299

BID: 15169, 15196, 15053