Brooky CubeCart < 3.0.4 Multiple XSS

Medium Nessus Network Monitor Plugin ID 3244

Synopsis

The remote web server contains a script that is vulnerable to a Cross-Site Scripting (XSS) attack.

Description

The remote host is using Brooky CubeCart, an online storefront application written in PHP. This version of CubeCart is vulnerable to multiple XSS Injection flaws. An attacker exploiting these flaws would need to be able to convince a user to browse to a malicious URI. Successful exploitation would result in code execution within the user's browser that could lead to theft of authentication materials.

Solution

Upgrade to version 3.0.4 or higher.

Plugin Details

Severity: Medium

ID: 3244

File Name: 3244.prm

Family: CGI

Published: 2005/09/29

Modified: 2016/01/21

Dependencies: 1442

Risk Information

Risk Factor: Medium

CVSSv2

Base Score: 4.3

Temporal Score: 3.7

Vector: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

Temporal Vector: CVSS2#E:H/RL:OF/RC:C

CVSSv3

Base Score: 5.3

Temporal Score: 5.1

Vector: CVSS3#AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N

Temporal Vector: CVSS3#E:H/RL:O/RC:X

Reference Information

CVE: CVE-2005-3152

BID: 14962